ZENCART インストールできません

上記のジャンルにあてはまらない話題、雑談など
アバター
guwdgfowe
記事: 9
登録日時: 2009/10/30 16:11

ZENCART インストールできません

投稿記事by guwdgfowe » 2009/10/30 16:22

バージョン情報
OS FreeBSD 6.2
Perl 5.8.8
PHP 5.2.8 /5.2.4 /4.4.9 /4.4.7
Python 2.4.3
Ruby 1.8.4
httpd Apache/1.3.37 Ben-SSL/1.57 (Unix)
MTA qmail 1.03

パス情報
Perl 5.8.8 /usr/local/bin/perl
Perl 5.8.8 /usr/bin/perl
Python 2.4.3 /usr/local/bin/python
Ruby 1.8.4 /usr/local/bin/ruby
sendmail (qmail) /usr/sbin/sendmail
nkf 2.0 /usr/local/bin/nkf
gzip 1.2.4 /usr/bin/gzip
uuencode ---- /usr/bin/uuencode
uudecode ---- /usr/bin/uudecode
ImageMagick 6.2.0 /usr/local/bin/convert

※ CGI版 PHP の利用方法につきましては、ヘルプページをご参照ください。

PHP iniの設定情報
PHP 5.2.8
PHP 5.2.4
PHP 4.4.9
PHP 4.4.7

データベース情報
version port hostname
MySQL 4.0.27 3306 localhost
MySQL 5.0.45 3307 127.0.0.1
PostgreSQL 8.1.10 5432 127.0.0.1
上記のkddiサーバーを使いZENCARTをインストールできません
コードしかでてこなくて困っております。 知恵かしていたでけないでしょうか?  よろしくお願い致します。 :shock:
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: ZENCART インストールできません

投稿記事by kimono » 2009/10/31 10:59

こんにちわ。kimonoです :)

どんなコードが出ているのでしょうね。
環境だけではちょっと分からないですね。
アバター
guwdgfowe
記事: 9
登録日時: 2009/10/30 16:11

Re: ZENCART インストールできません

投稿記事by guwdgfowe » 2009/10/31 16:07

すいません。

インストールはなんとかできましたがテストでログインしようとおもい登録しましたが日本語で打った部分が文字化けします。

1267 Illegal mix of collations (ujis_japanese_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '='
in:
[select zone_id from zones where zone_country_id = '107' and zone_name = 'マ闊??λ???']
If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.
教えてください。
宜しくお願い致します。
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: ZENCART インストールできません

投稿記事by kimono » 2009/10/31 16:26

えっと、Zen Cartのバージョンも書いていませんが、日本公式の1.3.0.2であっておりますでしょうか?
もし、そうであれば、データーベースの文字コードはujis_japanese_ciで作成する必要があります。どうも、utf-8と混在しているようなメッセージですので、データーベースがutf-8になっていないでしょうか?もし、utf-8になっていた場合は、データーが入った後に文字コードを変換することはできませんので、一度データーベースを削除し、再度作り直して、文字コードを変換してみて、インストールしなおしてください。
ちなみに、データーベースの文字コードなどはphpmyadminなどのツールを使うとやりやすいです。phpmyadminの使い方などは検索してみると色々と載ってますので、調べてみてください。

後、PMでメッセージが来ましたが、何も隠すようなことではないと思いますので、こちらで書きますが、.htaccessでphpの利用するバージョンを決めているみたいですね。
記載の通り、設定すればいいのではないでしょうか?
アバター
guwdgfowe
記事: 9
登録日時: 2009/10/30 16:11

Re: ZENCART インストールできません

投稿記事by guwdgfowe » 2009/11/01 10:28

無事インストールできました。
原因は、.htaccessファイル内にPHPのバージョンを指定しなくてはいけなかったことです。


あと指摘どおりUTF-8に変換してしまって不具合が起きていました。

ありがとうございました。
:mrgreen:

“Zen Cart 雑談処「禅亭」” へ戻る