インストール時の「データベース設定」から進みません[永遠に未解決]

困った時はこちらで質問してください。回答を担当する人は特に決まっていませんので、分かる方は回答をお願いします。
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

インストール時の「データベース設定」から進みません[永遠に未解決]

投稿記事by tracnez » 2010/9/26 23:07

?Zen Cartのバージョン:zen-cart-v1.3.0.2-l10n-jp-6
?使用しているテンプレート(ZenCSSなど):なし
?使用言語(日本語か英語かなど):日本語
?サーバOSとバージョン (Apache 2.x):WinVista Apache 2.2
?PHPとMySQLのバージョン:PHP5.3.0 MySQL5.1.37
?ホスティングの場合はホスティングサービスの名前とコース:localhost
?何をしたらどうなったのか? (できるだけ詳しく)
?エラーメッセージの内容 (省略せずに)
?どこまで調べたのか? (どこまでを知っているのか?)

「:: Zen Cart設定 - データベース設定」まで問題なく進んで、

テーブルプリフィックスを"zen_"
データベースホスト名を"localhost" (実際に自分のPC上のlocalhostです)
データベースユーザ名を"root" (もちろん、MySQLで作成済みです)
データベースパスワードは"root" (もちろん、設定済みです)
データベース名を"zencart" (もちろん、MySQLで作成済みです)

と入力して、他はすべてデフォルトのままで「データベース設定を保存」を押すと
IE8が"Internet Explorer cannot display the webpage"となって、
しかもMicrosoft Windowsという窓が出てきて
"Apache HTTP Server stopped working and was closed"
というエラーメッセージが出ます。
Apacheは動いています。MySQLも動いています。

でも、これだけの情報では何がおかしいのか分かりません。
似たようなケースは
http://www.zen-cart.com/forum/showthread.php?t=129910
くらいで、どうも結局解決してないようです。
同じような症状になった方はいらっしゃいませんか?
必要であれば幾らでも補足します。どうか助けてください。お願いします。
最後に編集したユーザー tracnez on 2011/1/01 14:17 [ 編集 2 回目 ]
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: インストール時の「データベース設定」から進みません

投稿記事by kimono » 2010/9/28 12:28

こんにちわ。kimonoです :)

php5.3とありますが、5.3には対応していないためではないでしょうか?
もし、間違っていましたらすいません。
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

Re: インストール時の「データベース設定」から進みません

投稿記事by tracnez » 2010/9/28 19:33

それは本当ですか!?

Zen Cartの動作環境について
http://zen-cart.jp/61.html

Zen Cart動作環境

?PHP 4.1.x (※)
?MySQL 3.2.x
?Apache 1.3.x
※快適な動作の為にはPHP4.3.x以上であることが望ましいです。

・・・と書いてあったので安心してインストールを始めたのですが・・・。
「PHP4.3.x以上であることが望ましい」んではないんですか?
というか、PHP5.3では動作しないことを知っていて、何故その旨を書かないんですか?????

では、結局どうすればいいのですか?
まさかのバージョン・ダウンですか???
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: インストール時の「データベース設定」から進みません

投稿記事by kimono » 2010/9/28 19:50

単純にまだ追いついていないということになります。
それを書いた当時は、まだphp5.3はありませんでした。
現在は、本家の最新版の1.3.9はphp5.3対応しておりますが、日本語版などはできておりません。
多くの人が協力して、みんなで日本語版を早く作りたいと思っている今日この頃です。
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

Re: インストール時の「データベース設定」から進みません

投稿記事by tracnez » 2010/9/28 20:40

状況は理解しました。
では、(「PHP5.3に対応されるのを待つ」という訳にもいかなさそうですし)、PHP5.2にダウン・グレードするしか無さそうですね・・・折角の安定した環境なのですが・・・。
他の原因となりそうなものはすべて調べましたので、原因はこれだと思います。取り敢えず、原因らしきものが分かってよかったです。もし、PHP5.2でも動かなければ、また報告します。
ありがとうございました。

※「PHP5.3では動作しない」という旨は一日も早く書き足されるべきでしょう。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by ゲスト » 2010/9/29 09:12

http://www.zen-cart.com/forum/showthread.php?t=140960
をみて該当部分を修正すれば使えるようになると思いますよ。
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by tracnez » 2010/9/29 21:03

もう遅いですよ、とっくにPHP5.2をインストールしました。しかも、一度はPHP5.2が動作したんですが、前回までは入れてたGDライブラリが無いと言われて入れて、cURLが無いと言われて入れたら、Apache2.2が原因不明のエラーで起動しなくなりました(ちゃんと.iniファイルなんかは残してあります)。ネットにある情報を基に対策中ですけど、全然治りません・・・。だから、折角の安定した環境を変えたくなかったんですけど・・・。そのパッチも信用できませんね、日本語環境で動く保証もないですし、第一、普通のzen-cartがどう動くのかすらまだ確認してないですから、やめときます。というか、zencartやめようかしらん・・・。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by ゲスト » 2010/9/30 04:33

オープンソースやフリーソフトにはよくあること。
ましてこれだけのソフトを本業もあるのに"無償"で日本人向けに訳して改良も加えてくれているのだから。
これで怒るのでしたら本家を自分で訳して改良して利用するか、利用しない方が良いと思いますよ。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by ゲスト » 2010/9/30 22:35

tracnez さんが書きました:もう遅いですよ、


驚き。。
アバター
sae
記事: 24
登録日時: 2008/1/10 18:52

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by sae » 2010/10/07 22:22

1.3.9はphp5.3対応しておりますが、日本語版などはできておりません。
多くの人が協力して、みんなで日本語版を早く作りたいと思っている今日この頃です。


現在はある程度進んででいるのでしょうか?
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by kimono » 2010/10/09 17:04

現在はある程度進んででいるのでしょうか?


誰も全く動いてないですね。
なので、協力者を募って進めたいと思っております。
アバター
sae
記事: 24
登録日時: 2008/1/10 18:52

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by sae » 2010/10/23 14:45

kimonoさんご返信ありがとうございます。

そうですか・・・了解しました。

いつも、ローカライズ作業はどのような感じで行ってられるのですか?

その都度、バージョンごとにチームリーダーが決めるのでしょうか?

トピック違いと思いますが・・・・スミマセン。 :oops:
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by tracnez » 2011/1/01 14:15

なぜ、プロジェクトが動いてないのか?
なぜ、返事が来ないのか?
なぜ、未だにPHP5.3には対応していないという旨が書かれていないのか?

賢明な方ならすぐに気付くと思います。
既にもうzen-cartは時代遅れだからです。
土台が古いものをどう着飾っても古いものには変わりがない。
それを隠すために必死になっているのがこのコミュニティの人達です。
これを使うなら現在人気No.1のprestashopを多少ローカライズして使った方が100倍便利でしょう。

削除するならすればいい。
糞zen-cartなんて要らない。
あと、馬鹿な糞コミュニティは更に要らない。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by ゲスト » 2011/1/03 00:31

tracnez さんが書きました:なぜ、プロジェクトが動いてないのか?
なぜ、返事が来ないのか?


ちょっと前に変な事件があったんですよ。
内部で分裂するような。
同じような口調でいまのメンバーに文句を言い
内部分裂させるために、一人と提携したとか書き込んでね。
しかし、おっしゃっていることもあてはまっています。
このカートの基本設計はデフォのままだと
日本人ユーザーには受け入れにくいのが実情。
実際に、自分で誰かが使っているZENでショッピングしてみるとわかるんです。
ええ?面倒だよ!それ、いま聞くか?と。(登録時など)
でもそれをいろいろな人がカスタマイズして使いやすくするのが
このZENであって、古い!とかなんくせをつけないで
勝手に離れていけばいいと思いますよ。
クソとか書いても格好悪いだけ。ここは2chじゃないんだから。
それと文句をいうなら英語の元祖のほうへ英語で言ったほうがいいですよ。

しかしそんな私も実はZENは見放しました。(壊れたら専門家じゃないと直せない!というか、なんで壊れる!!??)
そして、いろいろな業者さんも見放しているところも多いです。
でも使っている人もいますし、うまくカスタマイズして
これがZENか?と関心するところもあります。
ようは、腕前と頭が良い人はうまく活用できるツールなんですね。
私は頭が弱いので、活用しきれなかったし、おっしゃるようにPHP5.3が駄目だと書いていない説明書に理解できないタイプですから。照
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[一応解決済み]

投稿記事by ゲスト » 2011/1/03 00:59

ゲスト さんが書きました:ちょっと前に変な事件があったんですよ。
内部で分裂するような。
同じような口調でいまのメンバーに文句を言い
内部分裂させるために、一人と提携したとか書き込んでね。


続きは雑談でやりませんか?
その事件は初耳なので詳しく聞きたいです
アバター
志田
記事: 526
登録日時: 2005/5/15 14:14
お住まい: 東京都
連絡を取る:

Re: インストール時の「データベース設定」から進みません[永遠に未解決]

投稿記事by 志田 » 2011/1/04 17:27

申し訳ありませんでした。

http://zen-cart.jp/?%C6%B0%BA%EE%B4%C4%B6%AD

にてPHP5.3では動作しない旨記載いたしました。

ご迷惑をおかけしまことにもうしわけありませんでした。
アークウェブ http:/www.ark-web.jp
きものリメイク comachi http://comachi-kimono.jp
アバター
ちなみに

Re: インストール時の「データベース設定」から進みません[そろそろ解決しましょうよ]

投稿記事by ちなみに » 2011/1/07 19:55

PrestaShopが人気ナンバー1ていうのは、2010年のオープンソースCMSアワードの結果でしたかね。
アメリカでの投票なのでしょうか。
PrestShopをローカルで試してみましたが、日本語化がイマイチで、まだまだ日本じゃ使い勝手が悪い気がしましたね。
確かに、モジュールの追加はZIPごと管理画面でインストールする方式なので、楽に思える感じでしたが、カスタマイズを繰り返している場合は、差分をきちんと検証してからでないと厳しいんじゃないかと。

ところで、中野さんのところで進めている管理画面のかんたん化プロジェクトってのは、実際進んでいるんでしょうか。
出来れば、そういう事も話せて盛り上がれたら、より良いコミュニティ掲示板になるのかなと。
アバター
tracnez
記事: 6
登録日時: 2010/9/26 22:57

Re: インストール時の「データベース設定」から進みません[永遠に未解決]

投稿記事by tracnez » 2011/1/10 09:53

ありがとうございます。
良心的な方もいらっしゃるんですね。
糞コミュニティは前言撤回します。

zencartの糞っぷりはここを読んでもらうとよいと思います:
http://webtecker.com/2008/04/22/8-best- ... solutions/

私の知る限り、この手の記事の中では最も多くの意見が寄せられたサイトです。
一体、この中の何人の方が「いいから、zencart(とosCommerce)はベスト8から外せ!」と怒り心頭で書いていることか。(ベストはどれかは分からないがとにかく、)zencartとosCommerceはベストどころか糞だ、ということです。

>2010年のオープンソースCMSアワードの結果

よくご存知で。アメリカで、というより、実質的には世界で、ですね。
機能的にはzencartなんか比較対象にもなりませんね。日本語化は各々でやればいいでしょう。そんなに難しいものでもないでしょう。

>申し訳ありませんでした。
>http://zen-cart.jp/?%C6%B0%BA%EE%B4%C4%B6%AD
>にてPHP5.3では動作しない旨記載いたしました。
>ご迷惑をおかけしまことにもうしわけありませんでした。

Way tooooooooooooooooooo late.
最初にこの投稿があってから三ヶ月半。
その間に何人かの馬鹿も湧いてきました。
オープンソースだから、と胡坐をかいていたわけですか。
その対応の遅さがあなたの無能っぷりを如実に表していますね。
一日も早くこのプロジェクトごと潰れてくださることを心から願っております。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[永遠に未解決]

投稿記事by ゲスト » 2011/1/11 00:37

tracnez さんが書きました:一日も早くこのプロジェクトごと潰れてくださることを心から願っております。

何様だか知らないがZen-Cart使わんならさっさと出てけ。誰も止めんぞ。

静観しとったが今まで何人の人がこのオープンソースに携わったのか知らんのか?ひょっこり出てきて荒らすな。設計が古いのはしょうがないだろ?新しいものを君の判断で使えばいいじゃないか。しかし君のような奴はどんなオープンソースを使っても干されるぞ。

言ってる内容をとやかく言うつもりはないが、物には言い方ってもんがある事を知らないようなお子様じゃ誰も相手にせんだろう。少なくともECサイトを運営しようとする立場の人間が発する言葉じゃない事ぐらい、いい加減分からんかね?

返信不要なので2度と書き込みするな。
書き込むならもう少し建設的な事を書き込んでくれ。
以後レスは返さん。馬鹿らしいので。
アバター
ゲスト

Re: インストール時の「データベース設定」から進みません[永遠に未解決]

投稿記事by ゲスト » 2011/1/11 01:03

ゲスト様
「荒らし」行為に関してはスルーがもっとも効果的ですので、よろしくご協力ください。

“Zen Cart 質問コーナー” へ戻る