Apacheが1.3系の場合、動かないでしょうか?

最新版Zen Cartについて不具合が見つかった場合はこちらで情報を共有してください。内容によっては今後の開発の参考とさせていただきます。
アバター
wanko
記事: 1
登録日時: 2013/1/05 23:59

Apacheが1.3系の場合、動かないでしょうか?

投稿記事by wanko » 2013/1/06 00:28

はじめまして、初めて投稿します。
Zen Cart v1.5.1 jp1の開発に携わった皆様 、大変お疲れ様でした。

私もインストールして試してみたいのですが、当方のサーバー(CoreServer)の Apache が
v1.3.41 でして、v1.5.1を動かす最低限の環境(Apache 2.0 以上)さえ持っていないようで、
インストールしても動かないのではと思っていますが、実際どのような問題が出るのでしょうか?

私のような方も居ると思われますので、このv1.5.1をここのWeb上でデモサイトとして動かして、
試験をできるようにして頂けると、大変嬉しく思います。是非ご検討ください。
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: Apacheが1.3系の場合、動かないでしょうか?

投稿記事by kimono » 2013/1/12 15:53

こんにちわ。kimonoです :)

Apache1.3系では動作しないと思われます。
これは最低利用条件に記載の通りになります。
どのようなといいますと、しっかりと調査しないと分かりませんが、基本的にapache2以上にて動くようなプログラムにZen Cart1.3より改変されています。
どうしてもApache1.3系で動作させたいのであれば、Zen Cart1.5.1を諦め、Zen Cart1.3系を利用するしかないと思います。
このバージョンアップの意味は、Zen Cart1.3系での多くのバグの修正や、最近のサーバー環境への対応でのプログラムの改変、セキュリティ周りの見直しがメインとなっているため、新しい環境への対応の部分がなくなってしまうと、Zen Cart1.5系の意味がかなりなくなってしまうということになると思われます。

また、Apacheの1.3は2010年の1月を持って最終版の1.3.42が公開され、こちらと共にサポートを終了しています。
今後は、元からあったサーバーでない限り、新規に1.3系のサーバーが作られることもないということもあるため、本家でもApache2以降にしたのではないかと思われます。
サポートが終了しているということは、基本的に脆弱性などの対応なども行わないということになるため、Zen Cart1.5のバージョンアップの重要項目である、セキュリティ面での強化の部分が意味をなさなくなるということになるのかと思われます。

恐らく、現在のサーバー会社でもどこかでApache2への移行は、php4→php5の場合同様に行われていくと思われます。

Zen Cart.jpとしては、そういった意味からも本家のバージョンをなるべくそのまま公開することを考え、Apache1.3への対応は行わないようにしていこうと思います。
本家で何かしらの形で対応していくような流れになった場合は、そちらに沿う形にしていきたいと思います。

“1.5.x公式版の不具合報告・改善要望” へ戻る