zen-cart-1.5.1-jp-1のインストールの不具合:ローカライズされない。  【解決済み】

最新版Zen Cartについて不具合が見つかった場合はこちらで情報を共有してください。内容によっては今後の開発の参考とさせていただきます。
アバター
h_k_sim
記事: 2
登録日時: 2012/12/27 11:38

zen-cart-1.5.1-jp-1のインストールの不具合:ローカライズされない。

投稿記事by h_k_sim » 2012/12/27 16:50

日本語環境が正しくインストールされない。

原因:mysql_utf8_japanese_localize.sql が実行されないため。
修正するファイル: zc_install/includes/classes/installer.php
修正内容:524行目に以下のコードを追加

コード: 全て選択

executeSql('sql/' . $this->getConfigKey('DB_TYPE') . '_' . $this->getConfigKey('DB_CHARSET') . '_' . $this->getConfigKey('language') . '_localize.sql', $this->getConfigKey('DB_DATABASE'), $this->getConfigKey('DB_PREFIX'));

修正済みファイルを添付します。
添付ファイル
installer.zip
(9.44 KiB) ダウンロード数: 436 回
アバター
kimono
記事: 1995
登録日時: 2005/9/27 13:30
お住まい: 大阪府大阪市天王寺区上本町
連絡を取る:

Re: zen-cart-1.5.1-jp-1のインストールの不具合:ローカライズされない。  【解決済み】

投稿記事by kimono » 2013/1/12 15:27

こんにちわ。kimonoです :)

報告ありがとうございました。
修正してアップロードしなおしておきました。

“1.5.x公式版の不具合報告・改善要望” へ戻る